• 0

Office 365 'tenantname' property doesn't work with the actual tenant name


Question

Hello,

This is something we've noticed a while ago, but, only sharing now since I forgot in the meanwhile.

When adding MS Office 365 env. into monitoring following the official documentation, at some point it's stated that one of the properties that should be set at the resource level is:

image.png.9cc1cac05de7271a782aa7ba5ea9162e.png

I've done this but, the property source for Office365Reports category fails when running (prop. source details below):

image.png.e30e27643ec3e6ba4ceeb4e4fb0d627a.png

The actual error states the 'tenant name' in context doesn't exist.
This gets solved if instead of using the tenant name we pass the tenant ID instead.

Just want to raise this to your attention to make sure if the documentation actually requires an update note or no.

Thank you!

Regards,

  • Upvote 1
Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Also to add here... 

According to the documentation the user account roles should be:

image.png.41331f635fdcccfb68c8977ac78df212.png

However, the DS below doesn't work only with those perms:

image.png.64681c548418c179f4948e662444ca0f.png

I had the need to add the role 'SharePoint admin' in order to make it work

image.png.5a4b87773789c42a7c6be4106f05a6b2.png

Tried all the 'Reader' roles & none is able to make it work :( 

Is there any other way to have it working without the need to grant 'Admin' privs to the user in context?
This is very important to us because we've clients that will not give us those type of privileges (100% sure).

Please advise here folks.

Regards,

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.