• 0

SQL showing No Data


Go to solution Solved by Mike Moniz,

Question

Hi Team,

I have a couple of collectors that are showing No Data for SQL Server. Now the SQL servers do not get used a lot as they are in a test environment, would that cause the collector to say "No Data" on all metrics? I have checked and I do not see "No Data" on other item such as CPU or memory which leads me to believe it is not a WMI issue as I have found in the past. Any ideas?

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
  • Solution

So WinSQLServer- DataSource doesn't use WMI but uses PERFMON. Looking at the bottom of the screenshots you can see it got "NaN" for several items. I can't speak for SQL directly but many times when I see perfmon issues in windows, it usually due to the counters missing on the system itself and that you need to repair them. I would google something like "perfmon mssql counters missing" and try reviewing some of the items listed there.

Link to post
Share on other sites
  • 0

To provide some more generic information when you see "No Data" on the resource page... The first thing I suggest you do is go to the Raw tab and use Poll Now. This actually can provide a lot of useful troubleshooting information. It will show what it attempted and the output or results. If you post a screenshot of it, we might be able to help out. You might want to block/blur out any sensitive information though.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.