• 0
Sign in to follow this  
ssplat

can't turn alert off for specific instances with Ansible

Question

Hi Everyone,

The LogicMonitor module for Ansible has that specific parameter 'alertenable' while using 'datasource as target to turn off alerts for specific instance in datasource group. However it's not working for me. Did anyone ever tried to use that parameter? 

https://docs.ansible.com/ansible/2.4/logicmonitor_module.html

---
- hosts: localhost
  vars:
    company: mycompany
    user: myusername
    password: mypassword
  tasks:
  - name: Create a host group
    logicmonitor:
      target: datasource
      action: update
      displaname: server.com
      alertenable: no
      id: 123
      company: '{{ company }}'
      user: '{{ user }}'
      password: '{{ password }}'
Edited by ssplat

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I'm trying to turn off the alerting for 'Memory usage' instance for a specific device, not all monitored instances on that device. 

Share this post


Link to post
Share on other sites
  • 0

Adding an action that isn't 'sdt' errored out with following message  {"msg": "Error: Unexpected action \"add\" was specified."} or this if i don't pass any action parameter {"msg": "missing required arguments: action"}. SDT is not what i'm trying to do.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this