• 0

Alert Can't connect https, but can curl from collector


Question

Got an issue where getting a status "5", can't connect on https-443 to a web server on AWS EC2.  But can connect to https site from public browser and using curl from the collector, without issue.

Running diagnostics through LM shows a timeout. The "Poll Now" data looks fine except Normal Datapoints shows errors.  These errors cannot be confirmed.

 

 

image.png

Edited by Frank Slicer
added text for clarity
Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

It does look like it's not able to communicate with the web server. Status 5 is "Network error" and it isn't showing any content or headers. Have you tried using the debug console !http command to see what it shows? It supports using https as a url. Do you have a proxy? I don't think LM collector will look at the windows/IE proxy settings while other software might.

 

Link to post
Share on other sites
  • 0

I'm able to send !http curl https://<url> . and !http https://<url> from the debug..... from the later I get....

HTTP response received at at: 2018-09-26 15:17:38.362. Time elapsed: 40ms
HTTP/1.1 200 OK
x-powered-by: node.js/8.9.2
accept-ranges: bytes
content-type: text/html
server: turtle.io/7.6.1 (Linux)
allow: GET, HEAD, OPTIONS
cache-control: no cache, no-store, must-revalidate
pragma: no-cache
expires: 0
last-modified: Tue, 25 Sep 2018 12:51:43 GMT
etag: "3375771597"
transfer-encoding: chunked
x-response-time: 0.38 ms
date: Wed, 26 Sep 2018 15:17:38 GMT
connection: close

<!DOCTYPE html>
<html>
  <head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <title>EPayApp</title>
    <meta name="description" content="">
    <meta name="viewport" content="width=device-width, initial-scale=1">

followed by the contents of the home page........

Link to post
Share on other sites
  • 0
  • LogicMonitor Staff

I had the same issue and was able to resolve it with the following steps:

1. Open ServerManager in host
2. Add Roles and Features
3. Before You Begin...Next,
4. Install Type...Next,
5. Server Selection...Next,
6. Select Web Server (IIS) > Select Add Features...Next
7. Web Server Role (IIS)...Next
8. Roles Services...Next
9. Confirmation...Install

10. Select the new IIS option from Left Pane > Right click your server name > Internet Information Services Manager

11. Expand hostname > Right click Default Website > Edit Bindings > Add > type: Https > SSL Certificate: My ADFS Cert > close.

12. Right click Default Web Site > Manage Website > Start

13. Go to your LMportal > ADFS Host > HTTPS-443 > Raw Data > poll now.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.